姐姐的指标3

来源:百度文库 编辑:神马文学网 时间:2020/06/03 00:32:44
 通达信软件. 这是一个选股公式,点击功能---专家系统---公式管理器---条件选股公式---- 其他类型-----新建---把源码复制粘贴进去---起一个名称( )----确定 ========================== 副图指标: 点击功能---专家系统---公式管理器---技术指标---- 其他类型-----新建---把源码复制粘贴进去---起一个名称( )----确定 ============================= 应用:1,选股:功能----选股器---条件选股---选择大跌选股公式---选择周期,一般为日线---加入条件----改变范围,选择上a,深圳a等等----选股入板块---新建板块---板块名称( ...选股板块),板块简称.. ,以后可以输入... 打开板块----执行选股; 2.副图指标:k线图页面,右键副图指标(页面下部分)----其他类型---[ ]--太累了 =========================== 
 
 几种实用的条件选股公式     条件选股公式:D!HMCSF (黑马草上飞) 缺省周期:日线 
  
  ==============================================================
  
  LCZ:=(C-MA(C,60))/MA(C,60)*100;
  
  A1:=COUNT(MA(C,60)>REF(MA(C,60),1),100)>95;
  
  A2:=COUNT(LCZ<20,100)>95;
  
  A3:=COUNT(C>MA(C,60),100)>80;
  
  A4:=C/REF(C,1)>1.04;
  
  A5:=V/CAPITAL*100>2.8;
  
  ZTJ:=A1 AND A2 AND A3 AND A4 AND A5;
  
  ZTJ AND (REF(BARSLAST(ZTJ),1)>20 OR BARSSINCE( ZTJ)=0);
  
  ==============================================================
  
  黑马草上飞:
  
  1、60日价格均线平稳上扬。
  
  2、日K线按照60日均线斜率震荡上行。
  
  3、经过大半年的震荡向上,终于向上突破。
  
  操作:
  
  发出信号后逢低积极介入。
  
  ==============================================================
  
  条件选股公式:D!LYT (老鸭头) 缺省周期:日线
  
  ==============================================================
  
  MA5 := MA(close,5);
  
  MA10 := MA(close,10);
  
  MA60 := MA(close,60);
  
  pday1 := barslast(cross(ma5,ma60));{5日均线上穿60日均线}
  
  pday2 := barslast(cross(ma10,ma60));{10日均线上穿60日均线,至此形成鸭颈部}
  
  pday3 := barslast(high=hhv(high,pday2));{形成头部,要下跌}
  
  pday4 := barslast(cross(ma10,ma5));{下跌后,5日均线和10日均线死叉}
  
  pday5 := barslast(cross(ma5,ma10));{回落不久,5日均线和10日均线形成金叉,形成嘴部}
  
  a1:= pday1>pday2 and pday2>pday3 and pday3>pday4 and pday4>pday5 and pday5<5;
  
  a2:= count(cross(ma10,ma5),pday2)=1;
  
  A1 AND A2;
  
  ==============================================================
  
  老鸭头:
  
  (1)采用5、10和60周期的价格平均线。当5日、10日均线放量上穿60日平均线后,形成鸭颈部。
  
  (2)股价回落时形成的高点形成鸭头部。
  
  (3)当股价回落不久,5日、10日均线再次金叉向上形成鸭嘴部。
  
  操作:
  
  (1)在5日、10日均线放量上穿60日平均线形成鸭颈部时买入。
  
  (2)在鸭嘴部附近成交量芝麻点一带逢低买入。
  
  (3)当股价放量冲过鸭头顶瞬间时介入。
  
  ==============================================================
  
  条件选股公式:D!LZMD (量芝麻点) 缺省周期:日线
  
  ==============================================================
  
  V1:=MA(V,40);
  
  HSL:=V/CAPITAL*100;
  
  A1:=COUNT(V/V1<1.3,14)>11;
  
  A2:=CROSS(HSL,2);
  
  A3:=C/REF(C,1)>1.025 AND C>OPEN;
  
  ZTJ:=A1 AND A2 AND A3;
  
  ==============================================================
  
  量芝麻点:
  
  成交量连续出现萎缩,在量柱体图上表现为小芝麻点,连续的小芝麻点与40日量平均线形成一个小水坑。
  
  操作建议:
  
  最好K线浅幅回档,且成交量越小越好,当放量上行时买入。
  
  ==============================================================
  
  条件选股公式:D!QLQS (青龙取水) 缺省周期:日线
  
  ==============================================================
  
  A1:=MIN(MA(C,5),MA(C,10))>MA(C,60) AND CROSS(MA(C,5),MA(C,10));
  
  A2:=MIN(MA(C,5),MA(C,10))/MA(C,60)<1.05;
  
  A3:=COUNT(V6;
  
  A1 AND A2 AND A3;
  
  ==============================================================
  
  青龙取水:
  
  1、在5日、10日、60日均线图上,5、10日均线起伏不定,日K线在60日均线上逶迤。
  
  2、龙头回到60日均线附近,犹如青龙取水,同时成交量萎缩
  
  3、然后大涨。
  
  操作:待龙头形成,成交量萎缩又放大后,逢低介入。
  
  ==============================================================
  
  条件选股公式:D!QSGT (轻松过头) 缺省周期:日线
  
  ==============================================================
  
  nday := hhvbars(high,120); {120日内最高价的周期数}
  
  nday1:= nday-10; {最高点之后10日}
  
  nday2:= nday+10; {庄家应该在nday1--nday2之间吸纳大部分筹码}
  
  a1 := nday>=30;{确保高点出现的周期数大于30}
  
  a2 := ref(sum(vol,20),nday1) > finance(7) * 0.4; {吸纳40%}
  
  VMA:=MA(Vol,40);{40日量均线}
  
  A3:=COUNT(Vol0.9;{成交量呈现芝麻点}
  
  A4:=Close>=hhv(high,120);{股价在冲击前高位}
  
  A5:=COUNT(Vol<(MA(vol,10)*1.3),10)>8;{近期无明显放量}
  
  A1 AND A2 AND A3 AND A4 AND A5;
  
  ==============================================================
  
  轻松过头:
  
  (1)前一个头部下方的成交量巨大,股价筑头后开始回档。
  
  (2)回档完毕后成交量呈量芝麻点,股价再次上扬冲击前一头部。
  
  (3)轻松冲过前一头部并未明显放量。
  
  操作:
  
  (1)在前一头部成交量巨大时跟进。
  
  (2)在回档完毕后成交量呈现芝麻点时逢低吸纳。
  
  (3)最经济、最大利润化的方法是在轻松过头前的一瞬间迅速介入。
  
  (4)前头部价格一般是上升浪的腰部。
  
  ==============================================================
  
  条件选股公式:D!SJCJD (三金叉见底) 缺省周期:日线
  
  ==============================================================
  
  nday := 5;
  
  down := close/llv(low,60)<=1.2;
  
  pma1 := ma(close,5);
  
  pma2 := ma(close,10);
  
  vma1 := ma(vol,5);
  
  vma2 := ma(vol,10);
  
  diff := ema(close,12) - ema(close,26);
  
  dea := ema(diff,9);
  
  ppday := barslast(cross(pma1,pma2));
  
  vvday := barslast(cross(vma1,vma2));
  
  macdday := barslast(cross(diff,dea));
  
  sjcjd:= if((ppday<=nday and vvday<=nday and macdday<=nday),1,0);
  
  ==============================================================
  
  三金叉见底:
  
  (1)当股价长期下跌后开始企稳筑底,而后股价缓慢上升。有时会同时出现5日和10日均价线、5日和10日均量线、MACD的黄金交叉点,这是股价见底回升的信号。
  
  (2)有时会伴随出现两阳夹一阴多方炮、出水芙蓉、量顶天立地和MACD上穿零线等图形。
  
  操作:
  
  (1)当出现三金叉后开始买入股票。
  
  (2)或等股价回档时在10日均线附近逢低吸纳。
  
  ==============================================================
  
  条件选股公式:D!SSCJD (三死叉见顶) 缺省周期:日线
  
  ==============================================================
  
  nday := 5;
  
  down := hhv(high,20)/high<=1.15;
  
  pma1 := ma(close,5);
  
  pma2 := ma(close,10);
  
  vma1 := ma(vol,5);
  
  vma2 := ma(vol,10);
  
  diff := ema(close,12) - ema(close,26);
  
  dea := ema(diff,9);
  
  ppday := barslast(cross(pma2,pma1));
  
  vvday := barslast(cross(vma2,vma1));
  
  macdday := barslast(cross(dea,diff));
  
  sscjd:= if((ppday<=nday and vvday<=nday and macdday<=nday),1,0);
  
  ==============================================================
  
  三死叉见顶:
  
  (1)当股价长期上涨后开始进入头部,而后股价缓慢下跌。有时会同时出现5日和10日均价线、5日和10日均量线、MACD的死亡交叉点,这是股价见顶回落的信号。
  
  (2)有时会伴随出现两阴夹一阳空方炮、断头铡刀MACD下穿零线等图形。
  
  操作:
  
  (1)当出现三死叉后坚决卖出股票。
  
  (2)或等股价反弹到10日均线附近逢高派发。
      
 
其它主副图指标;

 交叉见底(听说准确率99%)副/未来

 
XX:=((((CLOSE - MA(CLOSE,34)) / MA(CLOSE,34)) * 100)* 5);
B001:=(((((CLOSE - MA(CLOSE,42)) / MA(CLOSE,42)) ) * 100) * 5);
B002:=(((((CLOSE - MA(CLOSE,67)) / MA(CLOSE,67)) ) * 100) * 5);
B003:=(((XX + B001) / 2) - (B002 ));
B004:=(((0 - 100) * (HHV(HIGH,34) - CLOSE)) / (HHV(HIGH,34) - LLV(LOW,34)));
B005:=(((0 - 100) * (HHV(HIGH,42) - CLOSE)) / (HHV(HIGH,42) - LLV(LOW,42)));
B006:=(((0 - 100) * (HHV(HIGH,72) - CLOSE)) / (HHV(HIGH,72) - LLV(LOW,72)));
B007:=EMA((((B004 + B005) / 2) - B006),6);
B008:=REF(CLOSE,1);

B009:=((((SMA(MAX((CLOSE - B008),0),19,1) / SMA(ABS((CLOSE - B008)),19,1)) * 100) - 50) * 1.25);
B010:=((((SMA(MAX((CLOSE - B008),0),34,1) / SMA(ABS((CLOSE - B008)),34,1)) * 100) - 50) * 1.25);
B011:=((((SMA(MAX((CLOSE - B008),0),72,1) / SMA(ABS((CLOSE - B008)),72,1)) * 100) - 50) * 1.25);
B012:=EMA(((((B009 + B010) / 2) - B011) * 5),6);
B013:=((((0 - 1) * ((B007 + B003) + B012)) / 3) * 1.5);
B014:=B012;
B015:=B013;
B016:=EMA(B012,4);
B017:=B012;
KKM1:=B013;
DPM1:=EMA(B013,4);
多头:B017,color0000FF;
空头:KKM1,color00FF00;
多均:B016;
空均:DPM1;
B018:=IF(CROSS(B017,KKM1),28,0);
xd:5 ;
VARX:=B017;
C023:=KKM1;
C024:=B016;
C025:=DPM1;
C026:=WINNER(CLOSE);
W:=(DMA(C026,((VOL / CAPITAL) * 1)) * 100);
HWXWINNER:=W;
XD1:=EMA(W,6);
XWXMH:=XD1;
XD2:=MA(W,14);
庄家控盘:((HWXWINNER - XWXMH) * 10),COLORSTICK,LINETHICK2;
STICKLINE(cross(多头,空均),0,50,8,0) ,COLORRED;

 

 

 

趋势先机(副\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\未来)

M1:=WINNER( MA(CLOSE,1))*200;
M2:=WINNER(MA(CLOSE,20))*200;
Var1:=(CLOSE-LLV(LOW,80))/(HHV(HIGH,80)-LLV(LOW,80))*200;
Var2:=SMA(Var1,3,1);
Var3:=SMA(Var2,3,1);
Var4:=3*Var2-2*Var3;
Var5:=LLV(LOW,5);
Var6:=HHV(HIGH,5);
Var7:=EMA((CLOSE-Var5)/(Var6-Var5)*100,4)*2;
Var8:=EMA(0.667*REF(Var7,1)+0.333*Var7,2);
Var9:=3*Var7-2*Var8;
VarA:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
VarB:=POW(MA(LOW,5),2)+MA(LOW,5);
VarC:=POW(MA(HIGH,5),2)+MA(HIGH,5);
VarD:=(VarA-LLV(VarB,64))/(HHV(VarC,64)-LLV(VarB,64))*150+65-10;
VarE:=SMA(VarD,3,1)*1.5-100;
VarF:=SMA(VarE,3,1);
Var10:=3*VarE-2*VarF;
Var11:=(HIGH+LOW+CLOSE*2)/4;
Var12:=EMA(Var11,13);
Var13:=STD(Var11,13);
Var14:=(Var11-Var12)*100/Var13;
Var15:=EMA(Var14,5);
Var17:=EMA(Var15,13)+200-100;
Var18:=EMA(Var17,10);
Var19:=3*Var17-2*Var18;
Var1A:=Var2+Var7+VarE+Var17;
Var1B:=Var3+Var8+VarF+Var18;
Var1C:=Var4+Var9+Var10+Var19;
Var1D:=(HIGH+LOW+CLOSE)/3;
Var20:=(Var1D-MA(Var1D,34))/(0.015*AVEDEV(Var1D,34));
Var21:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);
Var22:=(HIGH+LOW+CLOSE+Var1D)/4;
Var23:=EMA(Var22,24);
Var24:=STD(Var22,24);
Var25:=(Var22-Var23)/Var24*100;
Var26:=(Var1D-MA(Var1D,24))/(0.015*AVEDEV(Var1D,24));
Var27:=EMA(Var25,5);
Var2A:=((Var27+Var26+Var20)/3+165)/4;
Var2B:=(EMA(EMA(EMA(Var2A,15),10),5)-25)*2+Var21;
Var2C:=(Var1A+Var1B+Var1C*30)/32/5-15;
Var2D:=EMA(Var2C,13);{13}
Var2E:=(Var2A+Var2C)/2/1.1;  
Var28:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
Var29:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
Var30:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
Var31:=REF(CLOSE,1);
Var32:=SMA(MAX(CLOSE-Var31,0),5,1)/SMA(ABS(CLOSE-Var31),5,1)*100;
Var33:=(HIGH+LOW+CLOSE)/3;
Var34:=(Var33-MA(Var33,14))/(0.015*AVEDEV(Var33,14));
Var35:=(Var28>=-15.8 AND Var28<=-12.2 AND Var29<=-20.8 AND Var30<=-27.5 AND Var32<=11.7 AND Var34<=-145)*100;
基础线:IF(Var35>0 ,100 ,0 ),COLORF00FF0;
多空比例:IF((M1-M2)>-0.02,M1-M2,-0.02),COLORF0F000;
超短:EMA(Var2E,3),colorred ;
短线:EMA(超短,5),colorwhite;
趋势线:EMA((Var2B+Var2D)/2,2) ,coloryellow;

 
 
  
散户看盘(副图)
{INPUT.:M(60,3,100),N(30,3,100);}


散户线: 100*(HHV(HIGH,M)-CLOSE)/(HHV(HIGH,M)-LLV(LOW,M));
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,5,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
主力线:EMA(J,6),COLORYELLOW;
VAR2:=REF(LOW,1);
VAR3:=SMA(ABS(LOW-VAR2),3,1)/SMA(MAX(LOW-VAR2,0),3,1)*100;
VAR4:=EMA(IF(CLOSE*1.3,VAR3*10,VAR3/10),3);
VAR5:=LLV(LOW,30);
VAR6:=HHV(VAR4,30);
VAR7:=IF(MA(CLOSE,58),1,0);
VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;
VAR9:=IF(VAR8>100,100,VAR8);
吸筹:STICKLINE(VAR9>-120,0,VAR9,6,1),COLORMAGENTA;
AA3:=(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21))*100-10;
AA4:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
AA5:=SMA(AA4,13,8);
走势:CEILING(SMA(AA5,13,8)),COLORRED,LINETHICK2;
AA6:=SMA(AA3,21,8);
买观注: STICKLINE(走势-AA6<-65,0,7,15,1);
DRAWICON(FILTER(J>REF(J,1)AND 走势>=REF(走势,1)AND 走势<25 ,5),走势,1);
卖观注: STICKLINE(走势-AA6>85,98,90,15,1),COLORFFFF00;
DRAWICON(FILTER(J85 ,5),J,2);

 

 

 

神奇均线 (主图指标)

Var1:=(2*CLOSE+HIGH+LOW+OPEN)/5;
A1: (EMA(Var1,3)+EMA(Var1,6)+EMA(Var1,12)+EMA(Var1,24))/4;
A2: EMA(A1,2);
A3: EMA(A2,2);
A4: EMA(A3,2);
A5: EMA(A4,2);
A6: EMA(A5,2);
A7: EMA(A6,2);
A8: EMA(Var1,2.78)*1.028;
A9: MA(OPEN,3.2)*1.028;
安全线: EMA(CLOSE,55), CIRCLEDOT;

短线高手(副图指标)
Var1:=(CLOSE*2+HIGH+LOW)/4;
SK: EMA(Var1,13)-EMA(Var1,21);
SD: EMA(SK,2);
多方能量: 2*(SK-SD)*3.8, LINESTICK;
空方能量: (-2)*(SK-SD)*3.8, LINESTICK;
强弱分界: 0, CIRCLEDOT;

多空博弈(副图指标)
     
Var1:=(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21))*100-10;
Var2:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
Var3:=SMA(Var2,13,8);
高抛: 90, POINTDOT;
低吸: 0, POINTDOT;
多方能量: SMA(Var3,13,8);
空方能量: SMA(Var1,21,8);
买进: IF(CROSS(多方能量,45),18,-4);
卖出: IF(CROSS(45,多方能量),18,-4);
强弱分界: 45, CIRCLEDOT;

短线快枪(副图指标)

Var1:=(2*CLOSE+HIGH+LOW+OPEN)/5;
安全线: EMA(Var1,55), CIRCLEDOT;
SK: SLOPE(EMA(Var1,2),7)*15+Var1;
SD: EMA(SK,2);
SJ: 2.8*SK-1.8*SD;
6, POINTDOT;
买一: IF(CROSS(SK,SD) AND SK<安全线,9.8,6);
买二: IF(CROSS(SK,安全线),9.8,6);
买三: IF(CROSS(SK,SD) AND SK>安全线,9.8,6);


波段之星(副图指标)

Var2:=(HIGH+LOW+CLOSE*2)/4;
Var3:=EMA(Var2,21);
Var4:=STD(Var2,21);
Var5:=((Var2-Var3)/Var4*100+200)/4;
Var6:=(EMA(Var5,5)-25)*1.56;
AK: EMA(Var6,2)*1.22;
AD: EMA(AK,2);
AJ: 3*AK-2*AD;
100, POINTDOT;
0, POINTDOT;
80, POINTDOT;
买进: IF(CROSS(AK,AD),58,20);
卖出: IF(CROSS(AD,AK),58,20);

财运亨通(副图指标)

Var1:=(2*CLOSE+HIGH+LOW+OPEN)/5;
高抛: 80, POINTDOT;
Var2:=LLV(LOW,34);
Var3:=HHV(HIGH,34);
SK: EMA((Var1-Var2)/(Var3-Var2)*100,13);
SD: EMA(SK,3);
低吸: 20, POINTDOT;
强弱分界: 50, POINTDOT;
Var4:=IF(CROSS(SK,SD),40,22);
Var5:=IF(CROSS(SD,SK),60,78);
卖出: Var5;
买进: Var4;

抄底逃顶(副图指标)

Var1:=(2*CLOSE+HIGH+LOW)/4;
T: 80, POINTDOT;
D: 20, POINTDOT;
Var2:=LLV(LOW,5);
Var3:=HHV(HIGH,4);
SK: EMA((Var1-Var2)/(Var3-Var2)*100,4);
SD: EMA(0.667*REF(SK,1)+0.333*SK,2);
Var4:=(HHV(HIGH,4)-Var1)/(HHV(HIGH,4)-LLV(LOW,4))*100-72;
漓江倒影: SMA(Var4,4,1), LINESTICK;
Var5:=(Var1-LLV(LOW,4))/(HHV(HIGH,4)-LLV(LOW,4))*100;
Var6:=SMA(Var5,2,1);
桂林山水: SMA(Var6,2,1), LINESTICK;
漓江: 12;


底顶侦探(副图指标)


Var1:=(2*CLOSE+HIGH+LOW+OPEN)/5;
Var2:=EMA(EMA(EMA(Var1,4),4),4);
SJ: (Var2-REF(Var2,1))/REF(Var2,1)*100, COLORSTICK;
SD: MA(SJ,2);
SK: MA(SJ,1);
Var3:=CROSS(SK,SD) AND SK<0;
Var4:=CROSS(SK,0);
Var5:=CROSS(SK,SD) AND SK>0;
买一: Var3, STICK;
买二: Var4 OR Var5, STICK;
Var6:=CROSS(SD,SK);
卖出: Var6, STICK;
强弱分界: 0, CIRCLEDOT;

短线精灵(副图指标)


Var1:=(2*CLOSE+HIGH+LOW+OPEN)/5;
Var2:=LLV(LOW,21);
Var3:=HHV(HIGH,21);
SK: EMA((Var1-Var2)/(Var3-Var2)*100,5);
SD: EMA(0.667*REF(SK,1)+0.333*SK,4);
Var4:=IF(CROSS(SD,SK) AND SK>=60,60,76);
Var5:=IF(CROSS(SK,20) OR CROSS(SK,SD) AND SK>20,20,5);
买进: Var5;
卖出: Var4;
高抛: 80, POINTDOT;
低吸: 20, POINTDOT;
强弱: 50, POINTDOT;
Var6:=LLV(LOW,55);
Var7:=HHV(HIGH,34);
Var8:=EMA((Var1-Var6)/(Var7-Var6)*100,3);
Var9:=(SK+Var8)/2;
VarA:=EMA(0.667*REF(Var8,1)+0.333*SK,2);
VarB:=EMA(Var9,5);
VarC:=EMA(0.667*REF(VarB,1)+0.333*VarB,2);
IF(VarB>=40,20,0);

主力进出(副图指标)

Var1:=(CLOSE*2+HIGH+LOW)/4;
Var2:=EMA(Var1,13)-EMA(Var1,34);
Var3:=EMA(Var2,5);
强弱分界: 0, CIRCLEDOT;
空方主力: (-2)*(Var2-Var3)*3.8, LINESTICK;
多方主力: 2*(Var2-Var3)*3.8, LINESTICK;


平滑乖离(副图指标)

{N: 1    20    6}
Var1:=(2*CLOSE+OPEN+HIGH+LOW)/5;
Var2:=(CLOSE-MA(CLOSE,n))/MA(CLOSE,n)*100;
Var3:=(EMA(Var2,3)+EMA(Var2,6)+EMA(Var2,12)+EMA(Var2,24))/4;
A1: EMA(Var3,2);
A2: EMA(A1,2);
A3: EMA(A2,2);
A4: EMA(A3,2);
A5: EMA(A4,2);
强弱: 0, CIRCLEDOT;
买进: IF(CROSS(A1,A5),-1,-5);
卖出: IF(CROSS(A5,A1),1,5);
A6: 3*A1-2*A2;


股海航帆(副图指标)

Var1:=(2*CLOSE+HIGH+LOW)/4;
Var2:=MA(Var1,7);
Var3:=Var2-MA(Var1,7/2)<0;
Var4:=Var2-MA(Var1,7/2)>0;
Var5:=BARSLAST(Var3);
Var6:=0-BARSLAST(Var4);
Var7:=IF(Var3<=0,Var5,Var6);
上买下卖: (-1)*Var7, VOLSTICK;
强弱分界: 0, CIRCLEDOT;

 

 

稳赢剑 ((副)
参数描述: N(1,100,12)M(1,100,20)}

 


RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
STICKLINE(REF(J,7)<0 AND J>1,10,0,10,0),COLOR00FF00;
VAR1:=(CLOSE-LLV(LOW,45))/(HHV(HIGH,45)-LLV(LOW,45))*100;
VAR2:=SMA(VAR1,3,1);
VAR3:=SMA(VAR2,3,1);
贵:=N,COLOR00FF00;
VAR4:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-
LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
VAR5:=CROSS(VAR4,10) AND VAR3抄底:IF(VAR5,90,1),COLORRED;
DRAWICON(VAR5,65,1);
DRAWTEXT(VAR5,30,'抄底'),COLORYELLOW;
备钱:IF(CROSS(10,VAR4),40,1),COLORFF00FF;
DRAWICON(CROSS(10,VAR4),45,1);
DRAWTEXT(IF(CROSS(10,VAR4),1,0),20,'$备钱'),COLORWHITE;
危机线: 80,COLORRED,POINTDOT,LINETHICK2;
中间线: 50,COLORFFCCCC,POINTDOT,LINETHICK2;
安全线: 10,COLORFF00FF,POINTDOT,LINETHICK2;
VAR6:=(2*CLOSE+HIGH+LOW)/4;
VAR7:=LLV(LOW,M);
VAR8:=HHV(HIGH,M);
VAR9:=EMA((VAR6-VAR7)/(VAR8-VAR7)*100,13);
VARA:=EMA(0.667*REF(VAR9,1)+0.333*VAR9,2);
战术线: VAR9,COLORYELLOW,LINETHICK2;
战略线: EMA(0.382*REF(VAR9,2)+0.618*VAR9,12),COLORBLUE;
STICKLINE(VAR9>VARA,VAR9,VARA,6,0),COLORRED;
STICKLINE(VAR9<=VARA,VAR9,VARA,6,0),COLOR00FF00;
VARB:=SUM(IF(CLOSE>REF(CLOSE,7),VOL,IF(CLOSEVARC:=SUMBARS(VOL,CAPITAL);
VARD:=IF(CLOSE>LLV(CLOSE,VARC),1,-1);
VARE:=IF(VARB>LLV(VARB,VARC),1,-1);
VARF:=VARD*VARE;
VAR10:=IF(VARF=-1,1,0);
关注:IF(VAR10 AND CLOSE=LLV(CLOSE,20) AND VAR3A1:=EMA(CLOSE,5);
A2:=EMA(CLOSE,10);
A3:=EMA(CLOSE,20);
A4:=EMA(CLOSE,40);
A5:=EMA(CLOSE,60);
{上穿月线:IF({CROSS(A1,A2) AND }{CROSS(C,A3),50,0),COLORYELLOW,LINETHICK2;}
{上穿季线:IF({CROSS(A3,A4) AND }{CROSS(C,A5),50,0),COLORRED,LINETHICK2;}
I:=MA(BARSLAST(HIGH=HHV(HIGH,16))*IF(CLOSER:=MA(BARSLAST(LOW=LLV(LOW,18))*IF(CLOSE>OPEN,VOL,1),4);
短线逃顶:=IF(I,0,1),COLORGREEN;
DRAWICON(短线逃顶,90,2);

 

 

 

 

 

雨季彩虹(副)


YS1:=(HIGH+LOW+CLOSE*2)/4;
RK3:=EMA(YS1,10);
RK4:=STD(YS1,10);
RK5:=(YS1-RK3)*100/RK4;
RK6:=EMA(RK5,5);
RK7:=EMA(RK6,10);
涨:EMA(RK6,10)+100/2-5,COLORRED;
跌:EMA(涨,4),COLORWHITE;
天晴了:IF(CROSS(涨,跌) AND 跌<-10,20,0),COLORCCCCFF;
雨季将来:IF(CROSS(跌,80),80,100),COLORFF3798;
彩虹1:EMA(跌,4),COLORFFFF50;
彩虹2:EMA(彩虹1,4);
彩虹3:=EMA(彩虹2,4),COLORYELLOW;
彩虹4:=EMA(彩虹3,4),COLORCC9900;
STICKLINE(涨STICKLINE(涨STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),5,0) ,COLOR0066FF;
STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),4,0) ,COLOR0088FF;
STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),3,0) ,COLOR0099FF;
DRAWICON(天晴了>0,20,3);
DRAWTEXT(CROSS(涨,跌) AND 跌<20 AND 跌>-10,40,'日出'),COLORFFFFFF;
DRAWTEXT(天晴了>0,-20,'天晴'),COLORCCCCFF;
VAR11:=SUMBARS(VOL,FINANCE(7)*100);
{SUMBARS为引用函数,表示累加到指定周期数; FINANCE为财务数据函数,N为返回财务数值。}
VAR22:=DMA(EMA(CLOSE,12),SUM(VOL,5)/3/CAPITAL);
VAR3:=(CLOSE-VAR22)/VAR22*100;
VAR4:=HHV(VAR3,VAR11);
VAR5:=LLV(VAR3,VAR11);
VAR6:=(VAR3-VAR5)/(VAR4-VAR5)*100;
K:=SMA(VAR6,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
MA1:=MA(J,3),COLORGREEN;
STICKLINE(FILTER(J>MA1 AND J<=3,5)=1 AND 跌<0,涨,涨+20,6,0);
DRAWTEXT(FILTER(J>MA1 AND J<=3,5)=1 AND 跌<0,60,'注意'),COLORRED;

 

 

 
  涨幅前兆(副)
Var3:=LLV(HIGH,240);
Var4:=100*(CLOSE-Var3)/Var3;
Var5:=REF(LLV(CLOSE,480),1);
Var6:=REF(HHV(CLOSE,480),1);
Var7:=100*(CLOSE-Var5)/(Var6-Var5);
Var8:=(CLOSE-LLV(CLOSE,981))/(HHV(CLOSE,981)-LLV(CLOSE,981))*100;
Var9:=(CLOSE-LLV(CLOSE,393))/(HHV(CLOSE,393)-LLV(CLOSE,393))*100;
VarA:=(CLOSE-LLV(LOW,981))/(HHV(HIGH,981)-LLV(LOW,981))*100;
VarB:=(CLOSE-LLV(LOW,393))/(HHV(HIGH,393)-LLV(LOW,393))*100;
VarC:=EMA(100*(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100)),5)/4;
VarD:=IF(DATE<1031231,IF(VarC>23.16,VarC,0),0);
VarE:=VarC<1;
VarF:=VarD;
Var10:=Var4<0 AND Var7<0;
Var11:=1;
Var12:=(HIGH+LOW+CLOSE*2)/4*Var11;
Var13:=EMA(Var12,21);
Var14:=STD(Var12,21);
Var15:=((Var12-Var13)/Var14*100+200)/4*Var11;
Var16:=(EMA(Var15,89)-25)*1.56*Var11;
Var17:=EMA(Var16,5)*1.22*Var11;
Var18:=EMA(Var17,3)*Var11;
Var19:=3*Var17-2*Var18*Var11;
Var1A:=IF(CROSS(Var19,Var17) AND CROSS(Var19,Var18) AND CROSS(Var17,Var18),1,0); Var1B:=IF(CROSS(Var17,Var19) AND CROSS(Var18,Var19) AND CROSS(Var18,Var17),1,0);
买点: IF(FILTER(Var8=0 AND VarE AND Var10 AND Var1A,5)=1,10,0), colorred;
卖点: IF(FILTER(Var8=100 AND VarF AND Var1B,5)=1,10,0), colorgreen;
Var1C:=EMA(100*(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100)),13)/4;
Var1D:=EMA(CLOSE,2)-EMA(CLOSE,89);
Var1E:=EMA(Var1D,30);
Var1F:=2*(Var1D-Var1E)*10;
Var20:=POW(Var1F,3)*0.1+POW(Var1F,2);
Var21:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));
Var22:=EMA(Var21*0.97,3);
Var23:=(HIGH+LOW+CLOSE)/3;
Var24:=(Var23-MA(Var23,14))/(0.015*AVEDEV(Var23,14));
Var25:=IF(YEAR<2008 AND Var1F>0.015,Var20,0)/45;
庄拉线: Var25,coloryellow ;
Var26:=EMA(CLOSE,2)-EMA(CLOSE,150);
Var27:=EMA(Var26,100);
Var28:=2*(Var26-Var27);
Var29:=POW(Var28,3)*0.1+POW(Var28,1);
Var2A:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));
Var2B:=EMA(Var2A*0.97,3);
Var2C:=(HIGH+LOW+CLOSE)/3;
Var2D:=(Var2C-MA(Var2C,14))/(0.015*AVEDEV(Var2C,14));
黑马线: IF( Var28>0.1,Var29,0)*5, colorred;
量价线: (CLOSE-MA(CLOSE,21))/MA(CLOSE,21)*100, colorwhite;
Var2E:=IF(FILTER(量价线>0 AND 量价线<3,5)=1,12,0);
涨幅前兆: IF(FILTER(庄拉线>0 AND 庄拉线<0.5 AND Var2E AND Var1C<3,10)=1,10,0), colorwhite;
选股利器: IF(FILTER(Var2E>0 AND Var1C<2 AND 庄拉线>0 AND 庄拉线<1 AND 黑马线>0 AND 黑马线<1.5 AND Var2E>0,5)=1,10,0),colorffffff; DRAWICON(买点>0,10,1);
DRAWICON(卖点>0,10,2);
DRAWICON(涨幅前兆>0,10,1);
DRAWICON(选股利器>0,10,1);

 

 

 
 智能MACD(副)

DIFF:(EMA(CLOSE,3) - EMA(CLOSE,13)),colorred;
DEA:EMA(DIFF,9),colorff00ff;
MACD:0.9*(DIFF-DEA), COLORSTICK;
if(diff<0,diff,0),coloryellow,linethick1;
if(diff<0,0,diff),colorred,linethick1;
if(diffif(diff>dea,dea,dea),colorff00ff,linethick1;
aa:=cross(diff,dea);
二次金叉买就赢:0 ,LINETHICK0;
加仓要等绿变红:0 ,LINETHICK0;
时间之窗做参考:0 ,LINETHICK0;
见到死叉快点逃:0,LINETHICK0;
     Var1:=(HIGH+LOW+CLOSE)/3;
Var2:=(EMA(Var1,2)+EMA(Var1,5)+EMA(Var1,8))/3;
Var3:=(EMA(Var1,6)+EMA(Var1,9)+EMA(Var1,12))/3;
Var4:=BARSCOUNT(CLOSE);
Var5:=HHV(HIGH,200);
Var6:=LLV(LOW,200);
Var7:=(Var5-Var6)/40;
Var8:=HIGH+Var7;
Var9:=LOW-Var7;
sjzc:=IF((Var4+0)/34=FLOOR((Var4+0)/34),50,0),COLORred,LINESTICK;
DRAWICON(sjzc ,0.09,1);

DRAWICON(CROSS(DIFF,DEA),DIFF-0.01,4);
DRAWICON(CROSS(DEA,DIFF),DIFF,2);

 
  通达信(未来)

AA:MA(WINNER(C*0.95)*100,3),COLORYELLOW;
AA,stick,COLORYELLOW,linethick2;
Var1:=1/WINNER(CLOSE);
Var2:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
Var3:=100-ABS(Var2);
Var4:=3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)-2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
Var5:=3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)-2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
Var6:=100-Var5;
Var7:=100-Var4;
Var8:=MA(WINNER(CLOSE*0.95)*100,3);
Var9:=IF(Var1>5,IF(Var1<100,Var1,Var3-10),0);
VarA:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VarB:=SMA(VarA,3,1);
VarC:=SMA(VarB,3,1);
探索: EMA(3*VarB-2*VarC,3),colorwhite;
主力: (-1)*(EMA(Var7,1)-50)+50,COLORYELLOW,linethick2;
Z1: MA(主力,9),COLORRED,linethick2;
VarD:=(-1)*(EMA(Var7,1)-50)+50;
VarE:=(-1)*(EMA(Var7,12)-50)+50;
LC := REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
天涯:if(rsi1>93 or (AA>90 and rsi1>80),80,100),;
海角: 0,colorgreen;
苦海:
EMA(100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14)),6),LINESTICK,;
ZS: MA(探索,3),COLORYELLOW;
ZM: MA(MA(探索,3),3),COLORGREEN;

 
 
VAR1:=99999999999;
VAR2:=(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21))*100-10;
VAR3:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
VAR4:=SMA(VAR3,13,8);
多方能量: SMA(VAR4,13,8);
空方能量: SMA(VAR2,21,8);
介入: IF(CROSS(多方能量,45),18,-4);

 强弱分界: 45, CIRCLEDOT;

 

 

 

 
   捕抓庄股起点(副)

    VAR1C:=(HIGH - MIN(OPEN,CLOSE));
VAR2C:=(CLOSE - OPEN);
VAR3C:=(MIN(OPEN,CLOSE) - LOW);
VAR4C:=(HIGH - LOW);
VAR5C:=((VOL * VAR1C) / VAR4C);
VAR6C:=((VOL * VAR2C) / VAR4C);
VAR7C:=((VOL * VAR3C) / VAR4C);
VAR8C:=((VAR5C - VAR6C) - VAR7C);
大机构:SUM(VAR8C,13) / MA(VOL,13) / 13,LINETHICK1,color0000ff;
小机构:SUM(VAR8C,21) / MA(VOL,21) / 21,LINETHICK1,colorFFFF00;
散户:SUM(VAR8C,30) / MA(VOL,30) / 30,colorFF00FF;
股票:SUM(VAR8C,125) / MA(VOL,125) / 125,LINETHICK2,color00FFFF;
VAR4:=MA(CLOSE,5);
VAR5:=MA(CLOSE,10);
VAR6:=MA(CLOSE,30);
VAR7:=MA(CLOSE,60);
VAR8:=EMA(COST(85),7);
VAR9:=EMA(COST(15),7);
VARA:=(SUM(((CLOSE * VOL) * 100),4) / SUM((VOL * 100),4));
VARB:=(INTPART((VARA * 100)) / 100);
VARC:=(SUM(((CLOSE * VOL) * 100),7) / SUM((VOL * 100),7));
VARD:=(INTPART((VARC * 100)) / 100);
VARE:=(SUM(((CLOSE * VOL) * 100),28) / SUM((VOL * 100),28));
VARF:=(INTPART((VARE * 100)) / 100);
短线趋势:(EMA(CLOSE,5) - EMA(CLOSE,10));
中线趋势:EMA(短线趋势,9);
VAR10:=((0 - ((100 * (HHV(CLOSE,5) - CLOSE)) / (HHV(CLOSE,5) - LLV(LOW,5)))) + 100);
VAR11:=((0 - ((100 * (HHV(CLOSE,10) - CLOSE)) / (HHV(CLOSE,10) - LLV(LOW,10)))) + 100);
VAR12:=((0 - ((100 * (HHV(CLOSE,20) - CLOSE)) / (HHV(CLOSE,20) - LLV(LOW,20)))) + 100);
VAR13:=((0 - ((100 * (HHV(CLOSE,30) - CLOSE)) / (HHV(CLOSE,30) - LLV(LOW,30)))) + 100);
VAR14:=REF(中线趋势,1);
VAR15:=中线趋势;
VAR16:=(VAR15 - VAR14);
VAR17:=REF(短线趋势,1);
VAR18:=短线趋势;
VAR19:=(VAR18 - VAR17);
VAR1A:=OPEN;
VAR1B:=CLOSE;
发现机构入场:IF((((((((VAR1A <= VAR4) AND (VAR1A <= VAR5)) AND (VAR1A <= VAR6)) AND (VAR1B >= VAR4)) AND (VAR1B >= VARF)) AND (VAR16 > 0)) AND (VAR19 > 0)),0.5,0),LINETHICK2,color66FF00;
短线指标:IF(((((CROSS(短线趋势,中线趋势) AND (短线趋势 < 0)) AND (中线趋势 < (0 - 0.2))) AND (VAR11 > 45)) AND (VAR16 > 0)),0.3,0.1),color66FF00;
 

 

量能饱和度(副)
量能饱和度

SAT:=(AMOUNT/C)/(HHV(AMOUNT,21)/HHV(C,21));
饱和度:IF(SAT>1,1,SAT)*100;
量能≤5:STICKLINE(饱和度<=5,5,饱和度+20,3,0),COLORRED;
量能5~80:STICKLINE((饱和度>5 AND 饱和度< 80),5,饱和度+8,3,0),COLOR5290FF;
量能80~97:STICKLINE((饱和度>80 AND 饱和度< 97),5,饱和度,3,0),COLORFFCC00;
量能≥97:STICKLINE(饱和度>=97,5,饱和度,3,0),COLORGREEN;
DIFF : (EMA(CLOSE,12) - EMA(CLOSE,26))*50,COLORCYAN,LINETHICK2;
DEA  : EMA(DIFF,9),COLORRED,LINETHICK2;
 

 

 

                实价线;

 实价线:(C-LLV(L,60))/(HHV(H,60)-LLV(L,60))*100,COLORWHITE;
A1:=(2*C+H+L)/4;
A2:=LLV(L,34);
A3:=HHV(H,34);
A4:=SMA((HHV(H,9)-C)/(HHV(H,9)-LLV(LOW,9))*100-70,9,1)+100;
A5:=(C-LLV(L,9))/(HHV(H,9)- LLV(L,9))*100;
A6:=SMA(SMA(A5,3,1),3,1)+100;
A7:=A6-A4;
底部区域:IF(A7>60,A7-60,0),COLORYELLOW;
持有:STICKLINE(REF(底部区域,1)<底部区域,底部区域,REF(底部区域,1),5,0),COLORF00FF0;
出货:STICKLINE(REF(底部区域,1)>底部区域,底部区域,REF(底部区域,1),5,0),COLOR00FF00;
中线持有:EMA((A1-A2)/(A3-A2)*100,13),COLORBLUE;
中线出货:EMA(0.667*REF(中线持有,1)+0.333*中线持有,2),COLORRED;
STICKLINE(中线持有-中线出货>0,中线持有,中线出货,8,0),COLORBLUE;
STICKLINE(中线持有-中线出货<0,中线持有,中线出货,8,0),COLORRED;